#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "\{"id":([0-9]*),[^}]*\}\|?"
Local $sString = "{"id":1145585,"label":"1145585: Project Z"}" & @CRLF & _
"{"id":1150322,"label":"1150322: Project Waka 1"}|{"id":1150365,"label":"1150365: Project Waka 2"}" & @CRLF & _
"{"id":1149240,"label":"1149240: Analysis of Technical Options"}|{"id":1149258,"label":"1149258: Check and Report"}" & @CRLF & _
"{"id":1148925,"label":"1148925: Change Management Review"}|{"id":1148920,"label":"1148920: Follow-Up Meetings"}|{"id":1148923,"label":"1148923: Launch Date Definition"}"
Local $sSubst = "\1;"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)