import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\{\"id\":([0-9]*),[^\\}]*\\}\\|?";
final String string = "{\"id\":1145585,\"label\":\"1145585: Project Z\"}\n"
+ "{\"id\":1150322,\"label\":\"1150322: Project Waka 1\"}|{\"id\":1150365,\"label\":\"1150365: Project Waka 2\"}\n"
+ "{\"id\":1149240,\"label\":\"1149240: Analysis of Technical Options\"}|{\"id\":1149258,\"label\":\"1149258: Check and Report\"}\n"
+ "{\"id\":1148925,\"label\":\"1148925: Change Management Review\"}|{\"id\":1148920,\"label\":\"1148920: Follow-Up Meetings\"}|{\"id\":1148923,\"label\":\"1148923: Launch Date Definition\"}";
final String subst = "\\1;";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}