$re = '/\{"id":([0-9]*),[^}]*\}\|?/';
$str = '{"id":1145585,"label":"1145585: Project Z"}
{"id":1150322,"label":"1150322: Project Waka 1"}|{"id":1150365,"label":"1150365: Project Waka 2"}
{"id":1149240,"label":"1149240: Analysis of Technical Options"}|{"id":1149258,"label":"1149258: Check and Report"}
{"id":1148925,"label":"1148925: Change Management Review"}|{"id":1148920,"label":"1148920: Follow-Up Meetings"}|{"id":1148923,"label":"1148923: Launch Date Definition"}';
$subst = "\1;";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;