$re = '/^(?:\d{1,3}(?:,\d{3})+|\d+)(?:\.\d+)?$/m';
$str = '10000000
10,000,000
10000000.00';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);