import re
regex = re.compile(r"(\n\n)?(\n)?", flags=re.MULTILINE)
test_str = ("Intro & Verse \n"
"A\n"
"Chorus \n"
"D.\n"
"E.\n"
"A...\n"
"A...\n"
"E...\n\n"
"D.\n"
"E.\n"
"A...\n"
"E...\n"
"Interlude \n"
"A\n"
"A(2)\n"
"Asus4\n"
"A\n"
"Verse 2 \n"
"A...\n"
"[8x]\n\n"
"F#m.\n"
"E.\n"
"A...\n"
"A...\n"
"A...\n\n"
"F#m.\n"
"E.\n"
"A...\n"
"D.\n"
"E.\n"
"A...\n"
"Chorus 2 \n"
"D.\n"
"E.\n"
"F#m...\n"
"A...\n"
"E...\n\n"
"D.\n"
"E.\n"
"F#m...\n"
"E...\n"
"Turnaround \n"
"A...\n"
"Asus2...\n"
"Asus...\n"
"A...\n\n"
"A/D...\n"
"Bm7...\n"
"Asus...\n"
"A...\n"
"Bridge \n"
"A...\n"
"[8x]\n\n"
"F#m\n"
"D\n"
"A\n"
"A\n"
"[3x]\n\n"
"F#m\n"
"D\n"
"E\n"
"E\n"
"Outro \n"
"A...\n"
"[4x]\n"
"D...\n"
"[2x]\n"
"A...\n"
"[2x]")
subst = "\\1"
result = regex.sub(subst, test_str)
if result:
print(result)