using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((?:P2 x=\"")(.*?[^\""]+)(?=.+((?:P3 x=\"")(.*?[^\""]+))))";
string substitution = @"P2 x=""\4";
string input = @"<P1 x=""-0,36935"" y=""0,26315""/><P2 x=""4,29731"" y=""0,26315""/><P3 x=""5,29731"" y=""-0,40351""/><P4 x=""-0,36935"" y=""-0,40351""/>
<P1 x=""4,64065"" y=""0,26315""/><P2 x=""5,97398"" y=""0,26315""/><P3 x=""5,30731"" y=""-0,40351""/><P4 x=""4,64065"" y=""-0,40351""/>";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}