const regex = /((?:P2 x=\")(.*?[^\"]+)(?=.+((?:P3 x=\")(.*?[^\"]+))))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((?:P2 x=\\")(.*?[^\\"]+)(?=.+((?:P3 x=\\")(.*?[^\\"]+))))', 'gm')
const str = `<P1 x="-0,36935" y="0,26315"/><P2 x="4,29731" y="0,26315"/><P3 x="5,29731" y="-0,40351"/><P4 x="-0,36935" y="-0,40351"/>
<P1 x="4,64065" y="0,26315"/><P2 x="5,97398" y="0,26315"/><P3 x="5,30731" y="-0,40351"/><P4 x="4,64065" y="-0,40351"/>`;
const subst = `P2 x="\4`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);