# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"((?:P2 x=\")(.*?[^\"]+)(?=.+((?:P3 x=\")(.*?[^\"]+))))"
test_str = ("<P1 x=\"-0,36935\" y=\"0,26315\"/><P2 x=\"4,29731\" y=\"0,26315\"/><P3 x=\"5,29731\" y=\"-0,40351\"/><P4 x=\"-0,36935\" y=\"-0,40351\"/>\n"
"<P1 x=\"4,64065\" y=\"0,26315\"/><P2 x=\"5,97398\" y=\"0,26315\"/><P3 x=\"5,30731\" y=\"-0,40351\"/><P4 x=\"4,64065\" y=\"-0,40351\"/>")
subst = "P2 x=\"\\4"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.