package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([A-Za-z]+)\s*(\[?)\s*([A-Za-z]*)(\d*)\s*(\]?)\s*$`)
var str = `Abc[123]
Abc[]
Abc[xy33]
Abc
Abc [ 123 ] `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}