re = /^([A-Za-z]+)\s*(\[?)\s*([A-Za-z]*)(\d*)\s*(\]?)\s*$/m
str = 'Abc[123]
Abc[]
Abc[xy33]
Abc
Abc [ 123 ] '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end