$re = '/^([A-Za-z]+)\s*(\[?)\s*([A-Za-z]*)(\d*)\s*(\]?)\s*$/m';
$str = 'Abc[123]
Abc[]
Abc[xy33]
Abc
Abc [ 123 ] ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);