#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)((?:\d{1,2}:)?\d{2}:\d{2}\.\d{2,3})\h*-->\h*((?1))\R(.+)"
Local $sString = "908" & @CRLF & _
"59:44.940 --> 59:48.410" & @CRLF & _
"THE MICROPHONE BUTTON AND" & @CRLF & _
"" & @CRLF & _
"909" & @CRLF & _
"59:48.420 --> 1:00:06.450" & @CRLF & _
"THERE SHOULD BE AN OPTION TO UNMUTE DO" & @CRLF & _
"" & @CRLF & _
"910" & @CRLF & _
"1:00:06.460 --> 1:00:09.870" & @CRLF & _
"YOU SEE A MICROPHONE ICON ANYWHERE ON YOUR TEAMS" & @CRLF & _
"" & @CRLF & _
"911" & @CRLF & _
"1:00:10.280 --> 1:00:19.420" & @CRLF & _
"PLATFORM I'M" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")