# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"((?:\d{1,2}:)?\d{2}:\d{2}\.\d{2,3})\h*-->\h*((?1))\R(.+)"
test_str = ("908\n"
"59:44.940 --> 59:48.410\n"
"THE MICROPHONE BUTTON AND\n\n"
"909\n"
"59:48.420 --> 1:00:06.450\n"
"THERE SHOULD BE AN OPTION TO UNMUTE DO\n\n"
"910\n"
"1:00:06.460 --> 1:00:09.870\n"
"YOU SEE A MICROPHONE ICON ANYWHERE ON YOUR TEAMS\n\n"
"911\n"
"1:00:10.280 --> 1:00:19.420\n"
"PLATFORM I'M\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.