#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?um)^[ \p{L}]+$"
Local $sString = "GIORGI SHALAMBERIDZE" & @CRLF & _
"გიორგი შალამბერიძე" & @CRLF & _
"GIORGI SHALAMBERIDZE 4" & @CRLF & _
"გიორგი შალამბერიძე 4" & @CRLF & _
"John Doe" & @CRLF & _
"Charles III" & @CRLF & _
"Sr. Artur" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")