// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?um)^[ \p{L}]+$").unwrap();
let string = "GIORGI SHALAMBERIDZE
გიორგი შალამბერიძე
GIORGI SHALAMBERIDZE 4
გიორგი შალამბერიძე 4
John Doe
Charles III
Sr. Artur
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}