const regex = /^[ \p{L}]+$/umg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[ \\p{L}]+$', 'umg')
const str = `GIORGI SHALAMBERIDZE
გიორგი შალამბერიძე
GIORGI SHALAMBERIDZE 4
გიორგი შალამბერიძე 4
John Doe
Charles III
Sr. Artur
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}