const regex = /(<p><br><\/p>)*?$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(<p><br><\\\/p>)*?$', '')
const str = `<p>Olá</p><p><br></p><p><br></p>
<p>Olá</p><p><br></p><p><br></p><p><br></p>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}