re = /(<p><br><\/p>)*?$/
str = '<p>Olá</p><p><br></p><p><br></p>
<p>Olá</p><p><br></p><p><br></p><p><br></p>'
# Print the match result
str.match(re) do |match|
puts match.to_s
end