#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(https?:\/\/(?:www\.|(?!www))[a-zA-Z0-9][a-zA-Z0-9-]+[a-zA-Z0-9]\.[^\s]{2,}|www\.[a-zA-Z0-9][a-zA-Z0-9-]+[a-zA-Z0-9]\.[^\s]{2,}|https?:\/\/(?:www\.|(?!www))[a-zA-Z0-9]+\.[^\s]{2,}|www\.[a-zA-Z0-9]+\.[^\s]{2,})$"
Local $sString = "Допустимые адреса" & @CRLF & _
"" & @CRLF & _
"http://www.company.com" & @CRLF & _
"https://www.company.com" & @CRLF & _
"https://company.com" & @CRLF & _
"http://company.com" & @CRLF & _
"www.company.com" & @CRLF & _
"company.com" & @CRLF & _
"" & @CRLF & _
"http://www.company.com/some" & @CRLF & _
"https://www.company.com/some" & @CRLF & _
"www.company.com/some" & @CRLF & _
"" & @CRLF & _
"http://www.company.com/some%20address" & @CRLF & _
"https://www.company.com/some%20address" & @CRLF & _
"www.company.com/some%20address" & @CRLF & _
"" & @CRLF & _
"http://www.company.com/?sidebar=buyerDetail" & @CRLF & _
"https://www.company.com/?sidebar=buyerDetail" & @CRLF & _
"www.company.com/?sidebar=buyerDetail" & @CRLF & _
"" & @CRLF & _
"http://www.company.com/some/sidebar=buyerDetail" & @CRLF & _
"https://www.company.com/some/sidebar=buyerDetail" & @CRLF & _
"www.company.com/some/sidebar=buyerDetail" & @CRLF & _
"" & @CRLF & _
"Недопустимые адреса" & @CRLF & _
"" & @CRLF & _
"1http://www.company.com/some/sidebar=buyerDetail" & @CRLF & _
"1https://www.company.com/some/sidebar=buyerDetail" & @CRLF & _
"" & @CRLF & _
".http://www.company.com/some/sidebar=buyerDetail" & @CRLF & _
".https://www.company.com/some/sidebar=buyerDetail" & @CRLF & _
"" & @CRLF & _
".http://www.company.com/some/sidebar=buyerDetail" & @CRLF & _
".https://www.company.com/some/sidebar=buyerDetail" & @CRLF & _
"" & @CRLF & _
"com/some/sidebar=buyerDetail" & @CRLF & _
"+=.company.com/some/sidebar=buyerDetail"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")