import Foundation
let pattern = #"^(https?:\/\/(?:www\.|(?!www))[a-zA-Z0-9][a-zA-Z0-9-]+[a-zA-Z0-9]\.[^\s]{2,}|www\.[a-zA-Z0-9][a-zA-Z0-9-]+[a-zA-Z0-9]\.[^\s]{2,}|https?:\/\/(?:www\.|(?!www))[a-zA-Z0-9]+\.[^\s]{2,}|www\.[a-zA-Z0-9]+\.[^\s]{2,})$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Допустимые адреса
http://www.company.com
https://www.company.com
https://company.com
http://company.com
www.company.com
company.com
http://www.company.com/some
https://www.company.com/some
www.company.com/some
http://www.company.com/some%20address
https://www.company.com/some%20address
www.company.com/some%20address
http://www.company.com/?sidebar=buyerDetail
https://www.company.com/?sidebar=buyerDetail
www.company.com/?sidebar=buyerDetail
http://www.company.com/some/sidebar=buyerDetail
https://www.company.com/some/sidebar=buyerDetail
www.company.com/some/sidebar=buyerDetail
Недопустимые адреса
1http://www.company.com/some/sidebar=buyerDetail
1https://www.company.com/some/sidebar=buyerDetail
.http://www.company.com/some/sidebar=buyerDetail
.https://www.company.com/some/sidebar=buyerDetail
.http://www.company.com/some/sidebar=buyerDetail
.https://www.company.com/some/sidebar=buyerDetail
com/some/sidebar=buyerDetail
+=.company.com/some/sidebar=buyerDetail
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)