import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(https?:\\/\\/(?:www\\.|(?!www))[a-zA-Z0-9][a-zA-Z0-9-]+[a-zA-Z0-9]\\.[^\\s]{2,}|www\\.[a-zA-Z0-9][a-zA-Z0-9-]+[a-zA-Z0-9]\\.[^\\s]{2,}|https?:\\/\\/(?:www\\.|(?!www))[a-zA-Z0-9]+\\.[^\\s]{2,}|www\\.[a-zA-Z0-9]+\\.[^\\s]{2,})$";
final String string = "Допустимые адреса\n\n"
+ "http://www.company.com\n"
+ "https://www.company.com\n"
+ "https://company.com\n"
+ "http://company.com\n"
+ "www.company.com\n"
+ "company.com\n\n"
+ "http://www.company.com/some\n"
+ "https://www.company.com/some\n"
+ "www.company.com/some\n\n"
+ "http://www.company.com/some%20address\n"
+ "https://www.company.com/some%20address\n"
+ "www.company.com/some%20address\n\n"
+ "http://www.company.com/?sidebar=buyerDetail\n"
+ "https://www.company.com/?sidebar=buyerDetail\n"
+ "www.company.com/?sidebar=buyerDetail\n\n"
+ "http://www.company.com/some/sidebar=buyerDetail\n"
+ "https://www.company.com/some/sidebar=buyerDetail\n"
+ "www.company.com/some/sidebar=buyerDetail\n\n"
+ "Недопустимые адреса\n\n"
+ "1http://www.company.com/some/sidebar=buyerDetail\n"
+ "1https://www.company.com/some/sidebar=buyerDetail\n\n"
+ ".http://www.company.com/some/sidebar=buyerDetail\n"
+ ".https://www.company.com/some/sidebar=buyerDetail\n\n"
+ ".http://www.company.com/some/sidebar=buyerDetail\n"
+ ".https://www.company.com/some/sidebar=buyerDetail\n\n"
+ "com/some/sidebar=buyerDetail\n"
+ "+=.company.com/some/sidebar=buyerDetail";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}