#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^.*?(apple|banana|cherry).*?((?!\1)(?:apple|banana|cherry)).*?$"
Local $sString = "loved apple and banana." & @CRLF & _
"cherry is purple and banana is yellow." & @CRLF & _
"apple, banana, cherry are all fruits." & @CRLF & _
"" & @CRLF & _
"apple tastes good." & @CRLF & _
"a yellow fruit can be an banana." & @CRLF & _
"cherry is cherry"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")