re = /^.*?(apple|banana|cherry).*?((?!\1)(?:apple|banana|cherry)).*?$/m
str = 'loved apple and banana.
cherry is purple and banana is yellow.
apple, banana, cherry are all fruits.
apple tastes good.
a yellow fruit can be an banana.
cherry is cherry'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end