$re = '/^.*?(apple|banana|cherry).*?((?!\1)(?:apple|banana|cherry)).*?$/m';
$str = 'loved apple and banana.
cherry is purple and banana is yellow.
apple, banana, cherry are all fruits.
apple tastes good.
a yellow fruit can be an banana.
cherry is cherry';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);