using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"alpha[\h-]+beta[\h-]+gamma[\h-]+delta";
string input = @"alpha beta gamma delta
alpha beta gamma-delta
alpha beta-gamma delta
alpha beta-gamma-delta
alpha-beta gamma delta
alpha-beta gamma-delta
alpha-beta-gamma delta
alpha-beta-gamma-delta";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}