$re = '/alpha[\h-]+beta[\h-]+gamma[\h-]+delta/m';
$str = 'alpha beta gamma delta
alpha beta gamma-delta
alpha beta-gamma delta
alpha beta-gamma-delta
alpha-beta gamma delta
alpha-beta gamma-delta
alpha-beta-gamma delta
alpha-beta-gamma-delta';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);