re = /alpha[\h-]+beta[\h-]+gamma[\h-]+delta/m
str = 'alpha beta gamma delta
alpha beta gamma-delta
alpha beta-gamma delta
alpha beta-gamma-delta
alpha-beta gamma delta
alpha-beta gamma-delta
alpha-beta-gamma delta
alpha-beta-gamma-delta'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end