using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\. )(?:[ a-z\d-""'(),:;<>\/\\]|\.(?! ))+(\?)";
string input = @"Examination shows mild swelling around the left eye. Her left eye does not move past midline on far left gaze but moves normally when looking to the right. Without treatment, which of the following findings is most likely to occur in this 0.5 patient?";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}