import Foundation
let pattern = #"(\. )(?:[ a-z\d-"'(),:;<>\/\\]|\.(?! ))+(\?)"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"Examination shows mild swelling around the left eye. Her left eye does not move past midline on far left gaze but moves normally when looking to the right. Without treatment, which of the following findings is most likely to occur in this 0.5 patient?"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)