# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/[^\n\d,.]+//gm;t' <<< "123abs,5677
sdf123,455
1,sf4
"