const regex = /[^\n\d,.]+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[^\\n\\d,.]+', 'gm')
const str = `123abs,5677
sdf123,455
1,sf4
`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);