package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[^\n\d,.]+`)
var str = `123abs,5677
sdf123,455
1,sf4
`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}