# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\b<br \/>//gm;t' <<< "<p>1<br /><br />2<br /><br /><br />3<br /><br /><br /><br />4<br /><br /><br /><br /><br />5</p>."