import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^https:\\/\\/twitter.com\\/(?!messages|notifications|settings)[a-zA-Z0-9_]{4,15}($|\\/)";
final String string = "https://twitter.com/settings/account\n"
+ "https://twitter.com/messages\n"
+ "https://twitter.com/notifications\n"
+ "https://twitter.com/donate4_fun\n"
+ "https://twitter.com/donate4_fun/zxcqwe\n"
+ "https://twitter.com/nbryskin\n"
+ "https://twitter.com/jack\n"
+ "https://twitter.com/i/asd";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}