# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^https:\/\/twitter.com\/(?!messages|notifications|settings)[a-zA-Z0-9_]{4,15}($|\/)"
test_str = ("https://twitter.com/settings/account\n"
"https://twitter.com/messages\n"
"https://twitter.com/notifications\n"
"https://twitter.com/donate4_fun\n"
"https://twitter.com/donate4_fun/zxcqwe\n"
"https://twitter.com/nbryskin\n"
"https://twitter.com/jack\n"
"https://twitter.com/i/asd")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.