re = /^https:\/\/twitter.com\/(?!messages|notifications|settings)[a-zA-Z0-9_]{4,15}($|\/)/m
str = 'https://twitter.com/settings/account
https://twitter.com/messages
https://twitter.com/notifications
https://twitter.com/donate4_fun
https://twitter.com/donate4_fun/zxcqwe
https://twitter.com/nbryskin
https://twitter.com/jack
https://twitter.com/i/asd'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end