package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([^\t\r\n]*)\t([^\t\r\n]*)\t([^\t\r\n]*)$`)
var str = `AFRIKAANS South Africa ca
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}