$re = '/^([^\t\r\n]*)\t([^\t\r\n]*)\t([^\t\r\n]*)$/m';
$str = 'AFRIKAANS South Africa ca
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);