package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)![34]d(-?[\d\.]+)`)
var str = `/data=!3m1!4b1!4m5!3m4!1s0x310957360e265763:0x4a3989b09e7ae9c7!8m2!3d-11.520896!4d104.945442?hl=en`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}