re = /![34]d(-?[\d\.]+)/m
str = '/data=!3m1!4b1!4m5!3m4!1s0x310957360e265763:0x4a3989b09e7ae9c7!8m2!3d-11.520896!4d104.945442?hl=en'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end