re = /ua(\/)/m
str = 'https://avto-sila.com.ua/preobrazovatel-rzhavchiny
https://avto-sila.com.ua/prikurivatel-provoda-prikurivateli-2'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end