use strict;
my $str = 'INSERT INTO table (column1, column2, column3) VALUES (\'Alejandro\', \'dislike\', \'\', 20, \'otro nombre\')
INSERT INTO table (column1, column2, column3) VALUES (\'Jando\', \'like\', \'\', 30, \'wtf\')';
my $regex = qr/\bVALUES\s*\((?:\s*'(?:''|[^'])*'\s*,){2}\s*\K'(?:''|[^'])*'/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}