$re = '/\bVALUES\s*\((?:\s*\'(?:\'\'|[^\'])*\'\s*,){2}\s*\K\'(?:\'\'|[^\'])*\'/m';
$str = 'INSERT INTO table (column1, column2, column3) VALUES (\'Alejandro\', \'dislike\', \'\', 20, \'otro nombre\')
INSERT INTO table (column1, column2, column3) VALUES (\'Jando\', \'like\', \'\', 30, \'wtf\')';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);