re = /\bVALUES\s*\((?:\s*'(?:''|[^'])*'\s*,){2}\s*\K'(?:''|[^'])*'/m
str = 'INSERT INTO table (column1, column2, column3) VALUES (\'Alejandro\', \'dislike\', \'\', 20, \'otro nombre\')
INSERT INTO table (column1, column2, column3) VALUES (\'Jando\', \'like\', \'\', 30, \'wtf\')'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end