import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=:).*?(?=(?:\\r?\\n)+[^\\n]*$)";
final String string = "This is the title: \\ titles always have a colon\n"
+ "This is a regular sentence.\n"
+ "A sentence always ends with a period.\n"
+ "A sentence can\n"
+ "span multiple lines.\n"
+ "A sentence can contain numbers like 123.\n"
+ "The phrase can also contain \"text enclosed in double quotes\" or 'text enclosed in single quotes'.\n"
+ "Other symbols that may appear in sentences are\n"
+ "the comma ,\n"
+ "the semicolon ;\n"
+ "the dollar sign $\n"
+ "parentheses ( )\n"
+ "the plus sign + the minus sign - and the square brackets[ ].\n\n"
+ "This is an isolated phrase that the regular expression should not match.";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}