# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<=:).*?(?=(?:\r?\n)+[^\n]*$)"
test_str = ("This is the title: \\ titles always have a colon\n"
"This is a regular sentence.\n"
"A sentence always ends with a period.\n"
"A sentence can\n"
"span multiple lines.\n"
"A sentence can contain numbers like 123.\n"
"The phrase can also contain \"text enclosed in double quotes\" or 'text enclosed in single quotes'.\n"
"Other symbols that may appear in sentences are\n"
"the comma ,\n"
"the semicolon ;\n"
"the dollar sign $\n"
"parentheses ( )\n"
"the plus sign + the minus sign - and the square brackets[ ].\n\n"
"This is an isolated phrase that the regular expression should not match.")
matches = re.finditer(regex, test_str, re.DOTALL)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.