const regex = /(?<=:).*?(?=(?:\r?\n)+[^\n]*$)/sg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=:).*?(?=(?:\\r?\\n)+[^\\n]*$)', 'sg')
const str = `This is the title: \\ titles always have a colon
This is a regular sentence.
A sentence always ends with a period.
A sentence can
span multiple lines.
A sentence can contain numbers like 123.
The phrase can also contain "text enclosed in double quotes" or 'text enclosed in single quotes'.
Other symbols that may appear in sentences are
the comma ,
the semicolon ;
the dollar sign \$
parentheses ( )
the plus sign + the minus sign - and the square brackets[ ].
This is an isolated phrase that the regular expression should not match.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}