const regex = /^(?<type>\w+)(?:\((?<scope>.+?)\))?(?<major>!)?: */;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?<type>\\w+)(?:\\((?<scope>.+?)\\))?(?<major>!)?: *', '')
const str = `revert(scope): Revert "feat(scope): Commit message"`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}