re = /^(?<type>\w+)(?:\((?<scope>.+?)\))?(?<major>!)?: */
str = 'revert(scope): Revert "feat(scope): Commit message"'
# Print the match result
str.match(re) do |match|
puts match.to_s
end