$re = '/^(?<type>\w+)(?:\((?<scope>.+?)\))?(?<major>!)?: */';
$str = 'revert(scope): Revert "feat(scope): Commit message"';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);